Projektový plán v Excelu 2.0

Zdaleka největší čtenost má náš post s Excelem na zachycení projektového plánu. S ohledem na tento zájem, jsem se rozhodl publikovat zde i novu verzi našeho Excelu.

Při tvorbě nového Excelu jsem si dal za cíl excel zrychlit a zjednodušit případné uživatelské změny.  V průběhu práce na nové podobě se objevil ještě požadavek na přehled projektového plánu po týdnech (nejen po dnech).

Stará verze používala uživatelské vzorce a mnoho podmínek v podmíněném formátování. Nová verze používá jen vzorce v buňkách a jen velmi jednoduché podmíněné formátování. Cenou za rchlost je, že žížaly nemají dynamické ohraničení (jsou to pouze vyplněné buňky bez okrajů).

Výsledek v denním pohledu pak vypadá takto:

Projektový plán v Excelu – denní pohled

a týdenní pohled se stejnými daty:

Projektový plán v Excelu – týdenní pohled

Data sloupců A-E se do týdenního pohledu přenáší přes vzorce.

V denním pohledu je v každé buňce vzorec (uvedení příklad je pro buňku F4):

=KDYŽ(A(JE.PRÁZDNÉ($D4);JE.PRÁZDNÉ($E4));““;KDYŽ(A(F$2>=KDYŽ(JE.PRÁZDNÉ($D4);F$2;$D4);F$2<=KDYŽ(JE.PRÁZDNÉ($E4);F$2;$E4));$C4;“ „))

ten zajistí propsání písmene ze sloupce C do buňky pokud je datum z řádku 2 v intervalu od do – pokud je od nebo do vynechané, vyplní se všechny buňky od začátku (nebo do konce), jak je vidět i na příkladu výše.

Buňky projektového plánu (sloupec F a dál) pak mají nastavená jednoduchá pravidla podmíněného formátování:

Projektový plán v Excelu – pravidla podmíněného formátování

V případě potřeby je tedy možné tato pravidla upravit nebo přidat nová (nové barvy).

Pokud chcete mít „žížaly“ bez písmenek, pak jen nastavte barvu písma na stejnou barvu jako je barva výplně.

Nová šablona Excelu je ke stažení zde.

Budu rád za zpětnou vazbu.

SaveSave

SaveSave

Zanechat odpověď

Vyplňte detaily níže nebo klikněte na ikonu pro přihlášení:

Logo WordPress.com

Komentujete pomocí vašeho WordPress.com účtu. Odhlásit /  Změnit )

Google+ photo

Komentujete pomocí vašeho Google+ účtu. Odhlásit /  Změnit )

Twitter picture

Komentujete pomocí vašeho Twitter účtu. Odhlásit /  Změnit )

Facebook photo

Komentujete pomocí vašeho Facebook účtu. Odhlásit /  Změnit )

Připojování k %s

Tento web používá Akismet na redukci spamu. Zjistěte více o tom, jak jsou data z komentářů zpracovávána.